Cannot ssh to server on windows

Hello, after following the hands-on instructions I was able to deploy the sample service on (from windows).

Now I want to ssh to that server. First I hagve tried the fly ssh establish and got the following output:

C:\progr\html\test-fly>fly ssh establish
Automatically selected personal organization: Serafeim Papastefanos
Establishing SSH CA cert for organization personal

Error establish key failed: key exists and override not set

I had also run this yesterday for another test so I guess it should be fine.

Now I try to run fly ssh console and get the following output:

C:\progr\html\test-fly>fly ssh console
wg connect fdaa:0:358f::3 fdaa:0:358f:a7b:dc6:0:a:0 fdaa:0:358f::
Connecting to tunnel ⣾

This just hands in there playing the funny animation. Is it actually possible connect to the deployed instace from windows?

Hello, continuingg this issue, I tried deploying an app using linux and then fly ssh console worked without problems! So this problem is only when I try to connect from windows…