Site unresponsive, ERR_SSL_PROTOCOL_ERROR

Hi there, I’m unable to visit my site with ERR_SSL_PROTOCOL_ERROR. As far as I can tell, my application boots up successfully, is listening on 8080, and external 443 and 80 are open and mapped appropriately.

No Dockerfile, just standard-fare unmodified fly launch generated config file.

fly status reports health:

6586e65f	app    	1      	sea   	run    	running	1 total, 1 passing	0       	14m23s ago

Chris

This is using the <appname>.fly.dev host, right?

Yes, and just as a sanity check, I tried fly open from the CLI and it fails due to being unable to establish a secure connection.

Odd… I just launched a fresh app using a boilerplate Express node app from the Fly docs. I see in the logs:

2022-01-31T22:49:17.074 app[8a2274fd] sea [info] HelloNode app listening on port 8080!

And yet I also cannot resolve over HTTPS/HTTP, though those ports are indeed open and mapped.

This probably works without SSL, if you run curl http://<appname>.fly.dev. We’re looking at the SSL certificate issue to see what’s up.

1 Like

If it’s helpful information, that curl yields:

<html><body>You are being <a href="/authenticate">redirected</a>.</body></html>%

I think we found a bug preventing *.fly.dev certs from getting attached to new apps. Give us a few minutes and it should start working over ssl.

1 Like

I noticed this on Friday, was hoping it was just a flittering issue. Still seeing an issue today - perhaps related? Getting a cert revoked error with our custom domain, on an app that has been around for a couple months. Any ideas?

I’m sure you’re all working on it, but in case it’s helpful, I redeployed by instance again. I’m now receiving a different reply:

curl: (35) LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to

It’s not working, but it’s different. :slight_smile:

Seeing the same issue here on an app I just deployed (in case it matters - I repeatedly attempted to deploy the app last night UK time, but errors in my own code failed. Fixing those let me deploy successfully this morning, but several attempts were made around 12-14 hours ago).

Edit: I was able to get a ‘custom’ cert for my own hostname, CNAME that and things worked fine. Seems more like as kurt suggested it’s an issue assigning the default *.fly.dev certs.

Hi there!
I think I am facing the same issue. Just created a new Livebook via Livebook · Launch on Fly.io and I can’t connect to the website: https://yolobook.fly.dev/

Works again, thank you! :heart: