Site cannot be reached after deployment

I have been trying to deploy my remix app for a few weeks and have finally managed. However, when I try to access the deployed application, the response is THE SITE CAN NOT BE REACHED.

It has worked after adding port 8080 under env in fly.toml file

2 Likes

Just curious - did you use fly launch to get the app setup?

Yeah, that is what I used.

I’m having the same issue. I’ve tried tweaking it according to the official docs in hex and the page in fly.io, but I just can’t get it to work. I always get an ERR_CONNECTION_RESET

ERR_CONNECTION_RESET most likely means our proxy can’t connect to the app. If you run fly status, do you see any VMs running?

So, I ended up nuking it all and starting from scratch, following this Deploying on Fly — Phoenix v1.6.6, but omitting some steps of the deploy using releases doc. And it worked. I do not know why, however.

1 Like

If it worked, I’m happy! If you run into any more issues post 'em here though.

Similar problem.

Literally just followed the instructions for setting up a remix application.

flyctl status shows 2 running containers

Instances
ID              PROCESS VERSION REGION  DESIRED STATUS  HEALTH CHECKS           RESTARTS        CREATED
eb0f9d31        app     1 ⇡     cdg(B)  run     running 1 total, 1 critical     0               2m18s ago
517ae78d        app     0       lhr     run     running 1 total, 1 critical     0               6m22s ago

But same issue- it just hangs and times out.

Okay I have just found the issue…

For whatever reason, the flyctl launch command sets the internal port to 8080 for remix…

When the default port for remix is 3000