remix run failing to deploy

Hello! I am trying to deploy a very simple website and I am getting:

2022-02-02T23:20:27Z [error]Health check status changed ‘passing’ => ‘critical’

I tried to change the grace time following the troubleshooting, I tried removing the healthcheck, but no luck. Can you please help?

Hello! One thing that tripped me up that might also be a problem for you: Is the port listed in your fly.toml the same one as your app is listening on?

1 Like

Oh gosh, that was it! Thank you Louis! My bad doing this late at night and just expecting the auto-generated configuration to be correct.

1 Like

Easily done. Glad it’s sored :slight_smile:

I encountered the same issue. Indeed the port was wrong in fly.toml, but this file was auto-generated the first time I ran flyctl launch, so I think there is something you should fix somewhere (I just generated the remix app, did changed anything, and executed flyctl launch, it should know remix is using port 3000 by default and not 8080).

Thanks for the reports. I’ve been trying to reproduce this with a fresh remix app, but haven’t been able to so far. Which version of flyctl are you using?

I just ran into the exact same. Default generated fly.toml had 8080.

Installed the flyctl fresh today via PowerShell:

$ flyctl version
flyctl.exe v0.0.295 windows/amd64 Commit: c47821c BuildDate: 2022-02-03T16:00:09Z

FYI On it has the incorrect port mapping in the screenshot as well.

So the port mapping should be correct since fly.toml sets both the PORT environment variable, and the internal_port setting. One issue here may be that Remix is not using the PORT variable and listening on 3000 instead of 8080. In my tests with a fresh app, Remix listens on port 8080.

Can you post your fly.toml?

1 Like