Setting my app's name causes my app not to work

If I run fly launch and set the name to the name of my app “meresite” it will deploy, but requests never resolve and I get 2022-11-27T17:36:03Z proxy sea [error]Error: could not find an instance to route to in my fly logs.
But, if I do everything the same except with a randomly generated app name instead, everything works fine. Any idea what’s going on? I’d like to use my own app name if possible.


That’s strange :thinking:

The app name does need to be globally unique, and so it would make sense there was an issue if someone else already has an app with that same name. However given it does let you deploy, that wouldn’t seem to be the case. Plus your choice of name is simple and alphanumeric (without any special characters etc). So that’s fine too.

When you say “it will deploy” does the deploy complete and successfully end? If so, it should say it was successful and e.g 1/1 instances are ready. Or something of that nature. You can confirm that by running fly status and checking the list of vms. Are they all shown as running? Since if so … I’m not sure why the proxy could not route a request to one. But one thing at a time. You would need to first confirm the vm is there, and then at least you would have a vm id (from fly status) to provide to Fly to assist with debugging the proxy/route to it.

The only other thing I can think of is whether the name is conflicting with any name defined in fly.toml. Depending on where the code for your app came from, sometimes some example apps will have a fly.toml config file already provided. And so that file may have a name already defined. I wonder if that is causing any kind of confusion/conflict. Seems unlikely but worth taking a look.

Update: I see someone else got the same error message (Error: could not find an instance to route to) and so it is unlikely to be down to the app’s name. Much more likely to be an issue with Fly host/proxy. Which may have since been resolved (if this was the cause - may be unrelated of course):

Hi Greg, thanks for the responses. It looks like it was indeed a problem with whatever host my container was on. It’s working now!

Thanks again.

1 Like