Resized my VM and now MySQL database is empty (Repost)

I posted this about a month ago and didn’t receive any constructive responses. Nothing has changed since then, including the contents of the server, which I have also backed up. Any assistance in this is greatly appreciated. The database structure is in place, but all of its contents are gone. I have no idea what happened.

Original text:

I haven’t performed any sql operations that i know of. Funny enough I discovered this as I was starting to set up a backup of my db. I don’t know what could’ve caused it.

The volume ids are vol_g67340kkm1kvydxw, vol_0o6d42gg2n3v87gy. Help?

This is all the recent activity on it. The 2 day ago was me halving the ram to 1gb, in order to save some hosting costs. The 9 mins ago is me putting it back at 2gb in case that was the issue. It’s worked perfectly fine since before these changes.

Edit: for further context, I was in the process of deleting one of the above volumes (again trying to reduce costs as it is a largely unused db), but I stopped the process when I realized I should back up the db first. I’m not sure if the deletion went through, but the volume in question is still listed.

The database structure is also in place, except for one programmatically generated table, which leads me to that it was cleared during the vm resize.


Ok so after finding this thread, I ran fly ssh console -C "ls -lah /data/mysql", to the following output.

I’m not 100% sure but I think undo_00x might own contain the data I seek. Anyone have any idea how I may retrieve it?

Hello, sorry for the trouble. This is a bug with our deprecated Apps V1 platform. Your data is in the volume vol_0o6d42gg2n3v87gy, but updating the RAM on your VM created a new alloc that randomly picked the other volume.

I’ve manually updated your VM to point to the correct volume. The data should be present in your database again.
You can run fly migrate-to-v2 to migrate your database app (and your other apps) to the new Apps v2 platform, which is more reliable and doesn’t have many of the issues Apps v1 platform has. Of course, do take a backup before migrating your database!

Thanks for the redirect! It’s all working great now! I’ve backed up everything, and i’ll migrate in a few (this issue actually happened while I was about to start backing my db up haha)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.