Resized my VM and now MySQL database is empty

I haven’t performed any sql operations that i know of. Funny enough I discovered this as I was starting to set up a backup of my db. I don’t know what could’ve caused it.

The volume ids are vol_g67340kkm1kvydxw, vol_0o6d42gg2n3v87gy. Help?

This is all the recent activity on it. The 2 day ago was me halving the ram to 1gb, in order to save some hosting costs. The 9 mins ago is me putting it back at 2gb in case that was the issue. It’s worked perfectly fine since before these changes.

Edit: for further context, I was in the process of deleting one of the above volumes (again trying to reduce costs as it is a largely unused db), but I stopped the process when I realized I should back up the db first. I’m not sure if the deletion went through, but the volume in question is still listed.


The database structure is also in place, except for one programmatically generated table, which leads me to that it was cleared during the vm resize.

Ok so after finding this thread, I ran fly ssh console -C "ls -lah /data/mysql", to the following output.

I’m not 100% sure but I think undo_00x might own contain the data I seek. Anyone have any idea how I may retrieve it?


I think the flyctl ssh sftp command can help you download files from a VM.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.