Rails apps fail with "Connection reset by peer"

I’m trying to deploy rails app to fly.io but constantly see “Connection reset by peer”

Originally I thought something was wrong with my app, but I tried to create a fresh one based on this doc, and I see the same issue.

Fly status seems to be ok:

Curl from local machine:

Curl from fly server to prove that server started:

Also I tried to deploy node app with this doc but node app worked like expected.
Any thoughts?

I am able to connect to the app’s endpoint just fine; so, seems to be up and working now? Or, does the connection reset error crop up intermittently?

curl https://delicate-voice-1270.fly.dev -I 

HTTP/2 200 
x-frame-options: SAMEORIGIN
x-xss-protection: 0
x-content-type-options: nosniff
x-download-options: noopen
x-permitted-cross-domain-policies: none
referrer-policy: strict-origin-when-cross-origin
content-type: text/html; charset=utf-8
vary: Accept
etag: W/"d1d162f0b26c83b95cd7f2d61a104d93"
cache-control: max-age=0, private, must-revalidate
content-security-policy: script-src 'self' 'unsafe-inline'; style-src 'self' 'unsafe-inline'
x-request-id: 323b353c-c5ab-4c5d-a592-df7972f58722
x-runtime: 0.002737
fly-cache-status: MISS
date: Fri, 06 Jan 2023 15:17:29 GMT
server: Fly/0eb54ce6 (2023-01-05)
via: 2 fly.io
fly-request-id: 01GP3TH4DABCMWAE881MA8MMXC-aws

this is interesting
I just tried to turn on VPN and it works too.
This is the first time I see something like this.
so yeh, seem like it’s not fly problem, but my provider, I guess.

1 Like