One app can't connect to Postgres internal address

I’ve set the flag in the config, put both in the same organization (there) and yet one of my apps can connect while one of them can’t! All of them should be in FRA if I’m not mistaken.

  private_network = true

I also tried moving the app to SIN and it didn’t help either.

I’ve just moved my production db to fly and this is kinda weird. What do you think can be the reason?

there-nur can connect, but there-tower2 cannot.

Possible problems:

  1. Are these both running Prisma? Since DB servers are IPv6, some framework connection configs need tweaks to make it work.
  2. Did you create there-tower2 in the same organization, or create it and then move it? You need to deploy again to get private networking going after you move an app to a different org.
  1. Both prisma and on the same version.
  2. I moved both, but has re-deployed like 6 times. Although there-nur worked the first time even without the 6pn flag in config!

Could it be because the one failing is created a long time ago?

Do you want me try recreating and deploying there-tower2 in the new org from scratch?

It does look like there-tower2 isn’t getting the right organization network. I’ll fix that up now.

1 Like

If it’s much hassle, I can recreate one myself to save you some time.

It’s fixed!

1 Like