Can't connect to postgres after moving between organizations

I’ve been using wireguard to connect to my postgres instance with psql. I moved my instance between organizations, created a wireguard peer in that organization, disconnected from wireguard, connected to the new peer, and tried psql again, but I’m getting:

psql: error: could not translate host name “winter-night-5547.internal” to address: Name or service not known

Actually, I don’t think this is just a vpn problem. My fly app is getting the same error.

Apps need a redeploy after they move, which is a little tricky for postgres. It requires a few min of downtime to stop them and then start them up on the new private network.

Do you want me to go ahead and do that for your apps on the new org?

The command warned me about that so I assumed it would just happen. It’s down now anyway so do whatever you need to. Is this something I need to contact you to do in the future?

I really need to get this working. Is there something you have to do or is it something I should do?

You should be good now, sorry for the delay. This should be an automatic process, seems we just had a TODO that to-didn’t.

Hi @kurt! I have the same problem. My application can’t connect to the database after moving to the new organization. Is there a way to do this now?

apps:

shy-rain-1653 (elixir app)
brandkit-db-staging (postgres)

It seems like the Elixir app didn’t get set to the new network properly. You should be all set now, sorry about that.

1 Like