not enough compute capacity in Chicago (ORD)

Fly deploy does this:

Failed to start remote builder heartbeat: Couldn’t allocate volume, not enough compute capacity left in ord

Things that didn’t work:

  • Searching led to people saying “you can delete the builder and try again”, so I did that and tried again, but it schedules in ORD again
  • It also led to a thread suggesting that work was done in July to improve this scheduling, so I’ve tried a few times, but it doesn’t seem to be taking capacity into account or it wouldn’t pick ORD again, eh?
  • Local builder – boo; one of the reasons I liked Fly was the ability to pick and choose projects where I don’t require the occasionally-schlep-ful, always-resource-hogging local docker setups. Last resort probably.

Next up: trying VPN.

Tried a VPN into Dallas, deleting previous builder, and deploying. That initially failed with:

WARN Failed to start remote builder heartbeat: failed building options: failed probing “$ORGNAME”: context deadline exceeded

Error: failed to fetch an image or build from source: error connecting to docker: failed building options: failed probing “$ORGNAME”: context deadline exceeded

But then I tried it again, and it appears to be building! :blush: Aaaaaand – there it goes, deploy successful.

So – for anyone wondering – yes, it looks like you can use a VPN to poke around for regions with capacity until they can do that for you automatically.

(Note that in my case, I had to deactivate my internal Fly Wireguard VPN to activate my commercial, consumer web traffic VPN product – but I think it’d probably be possible to use just Fly for this bit as well)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.