Error when deploying example app


I’m new to fly, and I’ve been doing the guides from the docs.
I had no problems doing the “run a deno app” example. I succesfully deployed the app and even connected my own domain.

But when I do the “run a node app” example, I’m getting an error when I get to the flyctl deploy step:
Error unhandled upstream service error: could not fulfill resource requirements: not enough available dedicated CPUs to fulfill request of 2 cpus

Hey - which region are you trying this in?

I’ve tried it in Amsterdam and also in Paris iirc

I just tried it in frankfurt and madrid:

Hmm, this looks like another problem. flyctl is trying to build using your local Docker environment, but Docker appears not to be running. Could that be the case?

I saw the same warning when I did the deno quickstart, with no error. So my guess was that when the local docker fails, it tries to run it remote. That’s why I ignored the warning.

However I have the same problem when I add the --remote-only flag:

But, I changed the permissions for /var/run/docker.sock and now when I’m running without the --remote-only flag, it does work.
So I fixed my local environment, but remote is still not working for me. I can continue playing around with fly so I’m happy :slight_smile:

It’s seems like we’re currently out of capacity in the region that the remote builder is trying to start in, so if you do need a remote you could try pinning the builder (it’s just another app in your account) to a different region deleting the builder app and it’ll be created again when you redeploy.

Either way capacity will become available again in the future, so you could just retry.