No deployment available to monitor

I’ve had an app working for months now, and deploys have been pretty good. Yesterday I went to deploy a new version of the app and the deploy hangs and eventually returns this error:

Error 1 error occurred:
* No deployment available to monitor

When I searched the forum for similar issues, everything was from a few months ago and related to some issues Fly was having, and everything cleared up once Fly figured out what was going on.
One odd thing is that I can deploy one of the other apps I have on Fly without issue, just not this one. I tried rerunning, verified that the Docker builds are working, cleared the cache on the build machine, but nothing seems to make any difference.

Few folks have reported trouble with deployments: 1, 2, 3.

After some more troubleshooting, it looks like Fly isn’t actually creating a new release. When I run the deploy, it says that it has created a new version (along with the incremented version number), but if I check the deploy status it says the app isn’t being deployed, and then I check the versions, the new one isn’t listed.

1 Like

Well, in a last ditch effort I deleted my app and tried to create a new one using the existing code, but got the same result. So now I don’t have any version of the app available, and Fly continues to not trigger any kind of deploy.


Can you see if these steps work for you? remote builder machine stuck in created state - #6 by ray-chen

Also, does flyctl deploy --local-only <other-args> not work, too?