new vm stuck while running release_command

I think it’s related to New VMs stuck in "Pulling container image".

I have been trying again and again to deploy my app. first from my github action, and now I just run fly deploy -a XXX --config ./apps/webapp/fly.toml --image but get the following output:

==> Verifying app config
Validating ./apps/webapp/fly.toml
Platform: machines
✓ Configuration is valid
--> Verified app config
==> Building image
Searching for image '' remotely...
image found: img_0lq747mo7k846x35

Watch your deployment at

INFO Using wait timeout: 4m0s lease timeout: 13s delay between lease refreshes: 4s

Running XXX release_command: bash ./apps/webapp/scripts/
  Waiting for 148ede5cd12089 to have state: stopped

Error: release command failed - aborting deployment. error running 
release_command machine: timeout reached waiting for machine to stopped
 failed to wait for VM 148ede5cd12089 in stopped 
state: Get 
 net/http: request canceled
You can increase the timeout with the --wait-timeout flag

tried increasing the timeout to 4minutes (as you see in the output), but it didn’t help.
I thought maybe the docker image is big, but it’s ~500MB, downloads locally very fast.

ok, deployment now worked. the 148ede5cd12089 finished running after my command timed out (it feels like the API command to check for release command to finish didn’t respect my timeout parameter)

I just ran into the same thing, timeout after timeout, even though my release command takes a second at most :man_shrugging: in the end I killed the machine with fly m destroy and reran deploy.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.