My app is not getting deployed

My app is not deploying when I run fly deploy, no errors, everything works fine, it just hangs on vXYZ is being deployed, where XYZ is the version number. Nothing else on the screen.

Also, the app does not get deployed. How can I fix this?

I discovered this in the logs of the builder.

I also discovered that fly restart <appName> is not working anymore. It says <app> is being restarted but does nothing.
This is a weird problem. I am unable to deploy new versions of my app.

Try running fly status and then fly vm stop <id> of the running VM. This can sometimes get an app unstuck, especially if it’s using volumes. Nomad (which schedules these) can get in a state where it can’t figure out what it needs to stop in order to start a new thing.

fly restart is effectively the same as a deploy, just with the same image.

Nope, it didn’t work. I found something else, at the builder logs, I see it is doing the same thing repeatedly.

Also, it totally broke my app now. It is stopped and cannot be restarted in any way. I wonder if I delete the app, it will also delete the volumes. That means I will lose my data.

Please fix my application. It is causing problems to me now since it is down.

I deleted and re-created my app and it works now. However I lost all of the data in the app volume.