Machine API "Could not find image"

Hi! I’ve been trying to get a custom Docker image pushed up, which builds upon another Docker image with a few tweaks. Unfortunately, when trying to deploy it, the machine API endpoint reports the following:

{"error":"Could not find image \"\""}

This image does exist: and I’ve been able to pull it from other machines. Pushing it directly to yields the same result. I’m a little bit stumped since using the original, base image (couchdb) appears to work (unfortunately the default config doesn’t bind to IPv6 properly from what I can tell, hence my tweaked image).

The image file itself:

FROM couchdb

RUN echo "[chttpd]\nbind_address = ::\n\n" >> /opt/couchdb/etc/local.d/ipv6.ini

CMD ["/opt/couchdb/bin/couchdb"]

Does cache Docker images at some level, and it’s just a case of waiting for it to propagate? Or is there some piece I’m missing? The app itself is being deployed using the Terraform provider, so for completion’s sake here’s the Terraform file.

1 Like

Remote builders, in my experience, have no trouble pulling public images from other repositories (like docker hub). What you’re seeing might be an intermittent issue, possibly related to: Unable to deploy new version of app or scale servers - #7 by catflydotio

Yeah, you may want to also speak with u/CanRau to who tried couch on Fly earlier but not sure if they got it working: Can't get a CouchDB Cluster working (connection_closed)

Interesting! I hadn’t come across that thread, but once I’ve gotten something working I’ll be sure to contibute to it. I’ll give the image another shot tomorrow. Thanks :slight_smile:

1 Like

Unfortunately didn’t get it working with IPv6 only via separate apps over public IPv4 :cold_sweat:
Also currently not using Couch for anything :man_shrugging:t2:

Good news is Machine VMs have fixed IPv6 addrs (both public and private): Leftover DNS Records - #2 by jsierles (for the time being…)