Could not find image ""

Something weird is happening with the registry. I can publish an image but when I try to pull the same image I just pushed, it says it cannot be found. Is this a known issue?


There is some “stuff” going on:

That could be related! How are you pushing/pulling to the registry in your case?

I’m using github actions. Here is an example:
indie-stack/deploy.yml at main · remix-run/indie-stack · GitHub to publish

and for deploy:

Fly issues are all operational and this still seems to be broken. Weird thing is that I didn’t change anything regard how we do deployments.

1 Like

We have also been getting this error today, it seems there is quite an important delay before an image is actually available.


We are currently getting this error. It blocks our entire deployment pipeline.

Cross posting:

I investigated this error for quite awhile and while I don’t have anything concrete, I think the issue involves the Github action building the docker image for the “linux/amd64” platform (correctly) but when the fly cli is called, it’s not specifically looking for that platform and so it reports that the image cannot be found.

I’m dealing with this same issue. I’m also using the Remix Indie Stack and am unable to deploy to production. This is the error I’m getting and I see no way around it. I’ve tried deleting and creating the images but it’s not helping.

Searching for image '[name of project]:main-93f0d69e85f0c7f6c5784a10fcd3ecd622167679' remotely...
Error failed to fetch an image or build from source: Could not find image "[name of project]"

Yep same for us, we’re using the deployment action based on the remix indie stack which has been working perfectly fine until today


First time deploying to and I get this issue.

Is there any fix or sign of communication from

It seems that this has been going on for 9 days without a solution. Honestly, doesn’t make me feel confident.

I’m having this exact same problem. Not sure what to do.

We’re looking into this. It’s intermittent and only impacting some images. How are you building and pushing the problematic images?

So I’m now seeing a slightly different error from what everyone else is seeing, but suspect we’re all using roughly the same Github Actions “template” for a lot of this:

#25 exporting to image
#25 pushing layers 4.5s done
#25 ERROR: failed to push failed to copy: io: read/write on closed pipe
 > exporting to image:
ERROR: failed to solve: failed to push failed to copy: io: read/write on closed pipe
Error: buildx failed with: ERROR: failed to solve: failed to push failed to copy: io: read/write on closed pipe

Github Action code:

      - name: Build image 🐳
        uses: docker/build-push-action@v3
          context: .
          push: true
          tags:${{ github.sha }},${{ github.sha }}
          target: MY_SOURCE_LOCATION
          cache-from: type=gha
          cache-to: type=gha,mode=max

That looks like this issue, which is also related to a buildkit upgrade:

I’m following the instructions in the Indie Stack readme:

  1. fly apps create project-name

  2. Create a token and add to my Github repo

  3. Add a SESSION_SECRET to your fly app secrets: fly secrets set SESSION_SECRET=$(openssl rand -hex 32) --app project-name

  4. Create a persistent volume for the sqlite database: fly volumes create data --size 1 --app project-name

  5. Commit and push changes to my repo which results in a failed deploy

I’m also hitting this issue, following along with the Indie Stack Remix app…

Thanks @michael , seems that one was a one off (which I might have to deal with at some point in time), seeing this as everyone else on other deploys:

Run flyctl deploy --config fly.api.toml --image
==> Verifying app config
--> Verified app config
==> Building image
Searching for image '' locally...
Searching for image '' remotely...
Error failed to fetch an image or build from source: Could not find image ""

Publish step:

#25 exporting to image
#25 pushing layers 17.7s done
#25 pushing manifest for
#25 pushing manifest for 4.0s done
#25 pushing layers 2.8s done
#25 pushing manifest for
#25 pushing manifest for 3.3s done
#25 DONE 69.8s

I don’t happen to have a non-ARM64 machine handy to validate that the image is indeed pullable (when I try to pull I get the common error about:

no matching manifest for linux/arm64/v8 in the manifest list entries
cannot fetch image
1 Like

Thank you, Michael! Changing docker/setup-buildx-action@v2 worked for me! Finally deployed :grin:

1 Like