Kitty/Alacritty "unknown terminal type" with fly ssh console after updating flyctl


I’ve updated flyctl from 0.4xx to 0.521 and can’t really use Alacritty and Kitty when connecting to an instance via fly ssh console.

Using commands like “clear” would throw 'xterm-kitty': unknown terminal type. or 'alacritty': unknown terminal type.
Trying to execute htop would throw Error opening terminal: xterm-kitty.

It was working perfectly fine before upgrading (albeit not being able to do things like ctrl+l or use the up arrow key etc ootb).

It’s still working fine with x-term.

Should I install the terminal emulators I plan to use directly from my DockerFile ? (Have tried to install Kitty but there were some errors, I’m using the version from the Arch repos locally and thus would prefer to know if it’s worth trying to install it on the remote app before digging further)

(On a sidenote It’s a shame because Kitty has a super useful kitty +kitten ssh user@ip command that usually solves all problems on remote servers without having to import any local config but I guess there is no way to use it in combination with fly ssh console right ?)

I use kitty and have export TERM=xterm in my /etc/profile so this doesn’t happen with SSH. (kitty +kitten ssh seems better, thank you.)

I’m not sure what changed in flyctl for it to start showing these errors for you. I can’t reproduce them on flyctl v0.0.521, even with TERM env variable set to xterm-kitty.

Thanks for your response, using TERM=xterm solves the issue but isn’t recommended 'xterm-kitty': unknown terminal type · Issue #713 · kovidgoyal/kitty · GitHub , in few seconds I already noticed some problems like my prompt taking a second rather than instant to pop or the zsh auto suggestions not being colorized in gray.

I ended up installing kitty-terminfo with apt to get them there, it solved the unkown terminal problem althought it’s still not perfect (arrow keys, ctrl+l etc), I’ll try to copy them manually to see if it fixes everything.

Edit1 : Copying terminfos manually + running tic (Truly convenient SSH - kitty) is exactly the same as installing kitty-terminfo, it just solves the unkown terminal problem but ctrl+l arrow keys etc still don’t work, intriguing

Edit2: I just spawned a new Hetzner Ubuntu server and installing xterm-info fixes everything, technically why isn’t it the same with a fly app ?

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.