Issuing a certificate stuck awaiting

I’m trying to create a cert for a custom domain name, and it’s stuck “awaiting certificate”.

DNS is at Dreamhost, A/AAAA seem to be correct, their DNS checker thinks that the CNAME hasn’t propagated properly, but it seems to be OK (and things have worked for me before without it), the app (nginx) is configured for 443.

I had a bugger of time creating the new app (fly deploy doesn’t seem to honor PRIMARY_REGION in fly.toml), and I suspect I hit Let’s Encrypt rate limit for failed validations (as confirmed here). However, this appears to be an hourly limit, and it’s been almost a day.

It’s worked before, but I tore everything down and rebuilt it (to make sure that my setup documentation is correct), and I suspect something is wedged somewhere…

I deleted and re-created the app → same problem. Issuing a cert for a different sub-domain works, so if there’s something stuck somewhere that’s blocking the original cert request, could you please clear it out.

Thanks

1 Like