Issues connecting `fly-log-shipper` to Datadog

Hi all! We are trying to send Fly log to Datadog but we’re getting the following error when running fly-log-shipper:

vector::cli: Configuration error. error=unknown field `codec`, expected one of `only_fields`, `except_fields`, `timestamp_format` for key `sinks.datadog`

Is there anyone that knows what we are doing wrong?

We fixed it by modifying vector-configs/sinks/datadog.toml:

  1. Removing the encoding.codec = json
  2. We then got access denied errors, because the site wasn’t defined. We are using
1 Like

Hi @Yaeger

Yes, I was about to post about the encoding bug. I’ll create a PR to get that fixed.

Can you edit the datadog.toml again and add site = "" to see if that resolves your issue?

1 Like

Yep! Configuring site = works :slight_smile:

1 Like

Thanks for the confirmation ( and finding the issue ). We’ll get in a fix.

Perhaps adding a DATADOG_SITE env would be a nice option.

Its in the works: Datadog encoding fix plus site by draper7 · Pull Request #28 · superfly/fly-log-shipper · GitHub