How to install Supabase CLI in alpine linux app?

I have an alpine linux web app that runs my scheduled jobs. I want to add a new job that dumps my database data using supabase cli command db dump.

On my local development my new script runs fine. In the remote web app the script fails saying:

sh: no command supabase found

Locally I installed supabase cli using the npm install command. How should I install it to work properly in my web app.

I am using Dokcer container FROM alpine.

install supabase simply by using npm install,

You probably want to add to your Dockerfile something like RUN npm i -g [here's supabase cli]

I have already tried this does not make any difference. Also tried ssh console and installing it manually. After building the package with GO I managed to run the command. It gave me an error about Deamon not running.

It’s also possible to run the cli with npx supabase <command>.

That is what i am running and i get the Docker daemon is not running error

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.