HKG peer is having issues - macOS split DNS not working again

Running macOS 12.4

Hello! I have had apps up and running for over half a year. I work on Mac and have not had any trouble with Wireguard’s split DNS until about two days ago. The night before, it worked as expected. I started the next day and couldn’t access the internet and finally found out it was the Wireguard VPN connection.

I didn’t check with scutils --dns before as I never had an issue. I do see the new resolver entry when the VPN is connected. I set up dnsmasq and it’s configured the way I believe it should be. It can forward DNS as needed. However once the VPN starts, it takes over all DNS resolution, even if I configure the computer to use dnsmasq only.

So something appears to have changed. Wireguard didn’t so I suspect it’s a macOS component that changed. Any thoughts on how to get that split setup working again?

Thank you!

Perhaps this is isolated to just me. Does split DNS still work on macOS for others? Any way to reset it?

After creating another config to sanity check, it actually does not take over the DNS completely now. I don’t need to use dnsmasq to get access to my normal network. Unfortunately all *.internal domains are now inaccessible.

Now more curious. I originally started via the LAX gateway. I am now in Asia and had made a config via HKG. No problems. Time passed and I had this incident. As a sanity check I loaded up my original LAX gateway and voila. It works again. Now when I switch over to HKG no problem.

I’ll have to check my notes if there is something I didn’t do when creating the HKG gateway.

One good thing about this is that even when my local DNS was corrupted, fly commands worked including fly proxy so I could still connect to my .internal services and carry on. :+1:

I have been having intermittent problems accessing *.internal domains but just noticed Wireguard not working ? (+ Unable to create postgres) - #9 by shortdiv. Only my original lax peer reports alive and installed. sjc, ewr, and hkg are all down. I am currently in Taiwan. I’ll try creating some additional peers and see if they work as expected.

Even with the lax peer though I am not able to access all apps, though some of that may be due to recent like the “API error with request id…” issues.

As noted in the above wireguard issue, hkg peers are having trouble. I am having trouble on multiple peers except lax and sin with the exception of one app’s DNS not resolving. Everything else seems to be working.

Yup, we found a bug that appears to be preventing DNS lookups over some wireguard peers sometimes. We’re actively working on troubleshooting this one

Updated the status page to reflect this connectivity issue →

1 Like

The issue looks to have been resolved (see below for details on the issue), let us know if you’re still having trouble with the hkg peer

1 Like