Frustrating time with Elixir tutorial

I’ve been trying to follow the Elixir tutorial and have not had a good time.

It constantly hangs at Running Docker release generator following fly launch.
I’m using Windows 11 (I normally dev on OSX) with

elixir -v
Erlang/OTP 25 [erts-13.0.4] [source] [64-bit] [smp:16:16] [ds:16:16:10] [async-threads:1] [jit:ns]

Elixir 1.14.4 (compiled with Erlang/OTP 25)

and I’m not changing any files other than trying to run the basic tutorial steps.

I know I can pay 30 bucks to get “support”, but having the vanilla tutorial fail at this point is pretty disheartening.

1 Like

I got the basic site up by using a mac. It still failed in the launch withfailed to reload configuration file, but a subsequent manual call of fly deploy seems to have worked anyway.

Overall, my experience with “” has been pretty lackluster.

1 Like

Hi @darkmarmot. Sorry to hear you’re having a hard time with our Elixir getting started. I’m not on Windows, but other Windows users have fixed the issue of being stuck on Running Docker release generator by running mix phx.gen.release --docker first.

For macOS, could you post your output showing the error and where the failure occurred during the fly launch process? Did you do anything else before running fly deploy successfully?


Thanks for getting back to me! Here’s the full text I got on my mac leading to the error:

Preparing system for Elixir builds
Installing application dependencies
Running Docker release generator
Wrote config file fly.toml
? Would you like to deploy now? Yes
Error: failed to reload configuration file : open : The system cannot find the file specified.

Typed fly deploy after that and all seems to have worked.

I’ll try mix docker option as well!

Note that my friends and coworkers gave me crap for even trying to do this on Windows. I was only pursuing it as an “easier” path to assist my kids with this kind of thing.

1 Like

OK, mix phx.gen.release --docker did it for windows! :slight_smile: Thanks!
Oddly, I still get that config file error and can still deploy despite it.

That’s a pretty generic error message. I’d think it was referring to fly.toml, but then fly deploy wouldn’t work…
I’ll check in with some of my more seasoned colleagues, and hopefully we can figure it out, since it’s happening for you on both Windows and MacOS. Maybe posting your fly.toml file here would help.

Yeah, same results on both windows and mac with that error, both using Elixir 1.14.4 and OTP 25.

mac fly.toml:

# fly.toml app configuration file generated for dropbear-mac on 2023-04-21T11:39:29-05:00
# See for information about how to use this file.

app = "dropbear-mac"
primary_region = "iad"
kill_signal = "SIGTERM"

  release_command = "/app/bin/migrate"

  PHX_HOST = ""
  PORT = "8080"

  internal_port = 8080
  force_https = true
  auto_stop_machines = true
  auto_start_machines = true
    type = "connections"
    hard_limit = 1000
    soft_limit = 1000

    type = "tcp"
    interval = "15s"
    timeout = "2s"
    grace_period = "5s"

Hey @darkmarmot! It looks like you’ve run into a very recent bug in flyctl here. I’ve merged a fix over in Fix empty configFilePath regression in flyctl launch by haileys · Pull Request #2166 · superfly/flyctl · GitHub and we’ll get that released for you soon - sorry about the trouble you’ve had with this one!

1 Like

That new release is out, if you run flyctl version update you should be all good!