Deploying phoenix app - Stuck on Running Docker release generator

Just as in title. After running:
fly launch

I’m stuck for about 50 minutes on this:

Set secrets on rewards: SECRET_KEY_BASE
Preparing system for Elixir builds
Installing application dependencies
Running Docker release generator

Is this normal?

Hi @Infiplaya, same issue here.
Did you manage to solve? Any tip?
Thank you

I had this issue prior to having HELP - Error: UnhandledIoError(Os { code: 2, kind: NotFound, message: "No such file or directory" }) - #3 by Alezrik

if I ran mix phx.gen.release --docker it would make it past the hang, and would launch the app
unfortunately when I try to update/redeploy it I get the error in the link above now.

That worked!
I tried to make some minor changes and deploy a couple times and that deploy issue didn’t show up to me.
I will play around and see if the same issue with deploy also arises.
For comparison, I am on:

  • Win10,
  • Erlang/OTP 25 [erts-13.0.4] [source] [64-bit] [smp:8:8] [ds:8:8:10] [async-threads:1] [jit:ns]
  • Elixir 1.14.3 (compiled with Erlang/OTP 25)

Thank you very much @Alezrik .