fly launch failing on phx.gen.release

unable to fetch supported Docker image for Elixir 1.14.3 and Erlang 26.0.2

this is happening during the fly launch command.
when i look on the hexpm/bob? site the erlang 26 is not supported.

Happily i receive the same error when i run the command locally:
mix phx.gen.release --docker

My question is where are the elixir version and erlang versions written/stored? I don’t have a dockerfile as yet since the mix.phx.gen command does not complete and I believe this is where the docker file is written… I have searched through my code base and I don’t see it anywhere. Do i have to downgrade erlang and is there a reference to do that on a mac?

1 Like

Gave up trying to sort out elixir and Erlang versions.
I reinstalled my asdf installation.
Then I tried an opt 25 version of Erlang but it would not compile. So I installed Erlang 26.0.2 and used following to make it global on my local machine. asdf global erlang 26.0.2

I then installed matching. elixir: asdf install elixir 1.15.6-otp-26

recompiled everything and the fly launch worked.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.