flyctl update available, but it cannot update

I have installed flyctl using brew and every command I run I see:

~/dev/project ❯ fly status
Update available 0.0.412 -> v0.0.413.
Run "fly version update" to upgrade.

However, following it’s instructions:

~/dev/project ❯ fly version update
Update available 0.0.412 -> v0.0.413.
Run "fly version update" to upgrade.
/bin/zsh -c
Running automatic update [brew upgrade flyctl]
Warning: flyctl 0.0.412 already installed

It seems like brew is a bit behind, how do I fix this “annoyance” that it’s telling me to update even though it can’t, is there a env var I can set or something else to give Brew a little time to publish the update?

We automatically create a homebrew PR to update whenever a new version of flyctl is released, and it often takes a few hours or up to a day for that to get merged. That can sometimes cause this issue, and the answer is waiting a little longer (at least right now).

In this case the homebrew PR job failed. I fixed that, and the latest flyctl will be available via homebrew as soon as this PR is merged: flyctl 0.0.413 by flyio-buildbot · Pull Request #113318 · Homebrew/homebrew-core · GitHub

I totally understand, brew takes a minute to update.

But to me the DX is horrible, I feel like I have to update since it’s mentioned to me on every command I run (not every X commands or every X minutes but on every command) cluttering my output and there is no way to disable?

So if the update notification could be delayed a little or maybe even check if the update is available before starting to tell me every command (even the update command spews it out interestingly :sweat_smile:).

I would greatly appreciate it if the update “nag” could be disabled (with a env var maybe or some setting) and/or delayed from your side since it’s pretty distracting at the moment.

I get the following now — any tips? MacOS Ventura

❯ fly version update
/bin/zsh -c
Running automatic update [brew upgrade flyctl]
Warning: flyctl 0.0.557 already installed
Flyctl was updated, but the flyctl pointed to by homebrew is still version 0.0.557.
Please ensure that your PATH is set correctly!%

That version is extremely old. I’ll suggest you uninstall flyctl completely. There should also be a .fly folder in your root (~/.fly), remove that folder too. After, run a fresh install :slight_smile: