Fly on windows worked now not seeing command?

Im on windows 10, had to install via chocolatey and all went fine. App is up & hosted.
Went to make a few changes & redeploy, cli now saying its not finding any fly or flyctl commands? Choco installed 0.1.62 but when I ran the fly help command, it auto updated to 0.1.68 and now am yet again unable to use your fly cli commands in my app directory… where I was able to before.

This was already hard enough getting to work on windows, why would this auto update when I already had an installed version?.. then why did that update seem to break any availability to your cli commands??

Hello, I think I may be one of the only Windows users on the team so I definitely feel your pain.

I’d suggest sticking with our official Powershell-based installer under Windows. Right now the only third-party package manager we officially support is Homebrew, and given how much we struggle with that, I don’t see us adding Chocolatey/Scoop/Winget support anytime soon.

Sorry again. FWIW once installed we do auto-update so you won’t have to worry about keeping things updated.

1 Like

I second @nolan-fly, we highly recommend to stick to the official installer and leave autoupdate enabled. We are moving too fast at the moment to stick to any third party built version.

Did you have any issues with the official installer?

Thanks very much for the quick reply Nolan/guys, yes I actually did install using Powershell the first time, which installed fine but I was never able to access any fly or flyctl command in my apps directory… The only way I got the app finally hosted was to use a choco install I found online which allowed me to use the cli in my app directory.

Now that it auto-updated, I’m again unable to use the fly commands in my app directory. So should I just try a re-install using the powershell command again? Any tips on getting that to install globally so I can use the fly cli in my app directory?

This is what I’m seeing now when I try the powershell install command, it’s installing into .fly\bin but then trying to run the choco install:

Is there a symlink (can’t remember what windows calls these) from the exe in the chocolatey tools dir pointing towards a missing file?

You may have to remove the choco install completely. To be safe, I’d:

  1. choco uninstall flyctl or equivalent: haven’t used Chocolatey in years so don’t remember the exact incantation.
  2. Remove your ~/.fly/bin directory.
  3. Check your path and remove any fly-related directories added by either our installer or Chocolatey’s.
  4. Just to be extra extra careful with a cherry on top (this is Windows after all), start a new powershell.
  5. Rerun our installer. Hopefully everything is set up correctly, including your path.

Sorry you’re having a bad experience. I’ve reached out to the flyctl Chocolatey maintainer and offered to help make sure their package keeps working in spite of our auto-update. Hoping I’ll hear back soon.

1 Like

Hello @nolan-fly , chocolatey package mantainer here, I have actually fixed the installation & uninstall scripts of the chocolatey package to make use of the official installation directories (based on the official powershell installation script).

I cannot push another version because there will be mismatching versions between flyctl in github and chocolatey. Nevertheless, future versions of flyctl chocolatey installations will install in the desired path following this logic:

$BinDir = if ($FlyInstall) {
} else {

I have been testing and this will result in the autoupdate process to not fail, so both official installation script and chocolatey will do the same thing.

I will watch out for a further release and ensure its working great. Please if it fails in the future do not hesitate to contact me as you did :slight_smile:


Thanks Nolan & Piraces for the in depth help. I guess I need to uninstall my current choco package as Nolan mentioned then try a fresh powershell re-install?

I’ll try this but from what initially happened it seems I will likely only be able to use a choco install bc so far that is the only way I’ve been able to access fly commands from my app directory.

In either case the fast and thorough customer support received here is an absolute breath of fresh air! So many large companies I deal with and this is pretty much what is lacking from nearly all of them. Thanks again guys!.. have a great Sunday

Amazing! Thanks for the quick fix.

Uninstalled, removed .fly/bin directory… reinstalled, same exact result.
“Cannot find file at '…”

Cant run any flyctl commands in my app directory, yet again.
I work for an agency that will be focusing on Shopify app building and you guys are basically losing any developer $$ like me on windows with an experience like this.

Sorry to hear that. This is with the powershell-based installer or still with Chocolatey?

This ended up working again and hopefully it stays as is. I re-deleted and first tried the powershell install which did not work, tried choco install again and worked perfectly so idk but is working great now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.