fly launch keeps deploying my docker image without my consent

I need to mount a volume for persistence in fly.toml before deploying the app but fly launch deploys the app right away before even giving me the chance to add the volume in fly.toml. It never asks me “Would you like to deploy the app now?” NO, NO I DO NOT, but it never asks me that like it should, it just skips that part. Every single tutorial and guide ever made on “fly launch” in existence since the dawn of time, says that it should ask you that question after running “fly launch” and not deploy it automatically without the user’s consent. I’m so beyond frustrated and angry that my boss threatened to fire me for stopping work just to post this. If i don’t get an answer soon I swear im going to smack him in the face if he talks to me again. PLEASE HELP ME ASAP

fly launch --no-deploy


I tried fly launch --build-only and it seemed to work. I haven’t tried --no-deploy yet but the docs say all it does is not prompt you for it so not sure that one would work.

1 Like

hi @edwing

Are you getting the new UI where you can edit some of the settings? Do you need to edit some settings that don’t appear in the UI yet?

One option would be to create an app with fly apps create my-app-name, create a fly.toml file for it (presumably copied from another app) and then run fly deploy (all in your project source directory).

fly launch --no-deploy is the right answer here - it won’t deploy the app automatically.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.