Fly Api Error when running fly deploy

Hello, since yesterday when I try to deploy my app and run fly deploy in my terminal I get a Fly API Error. I had similar issue some time ago but then fly deploy--remote-only helped

--> Verified app config
==> Building image
WARN Failed to start remote builder heartbeat: You hit a Fly API error with request ID: 01H3ERE1VPVBTEYSTWQPZWZXPS-waw
Error: failed to fetch an image or build from source: error connecting to docker: You hit a Fly API error with request ID: 01H3ERE7CRC996ZRSVS7AA32W9-waw

I have tried:

  • Using fly deploy --remote-only
  • Destroying the builder app
    But it still does not work.


Check out the following:

EDIT: Just tried deploying right now, and whatever was wrong has been fixed.

I’m having the same problem, I’ve also tried:

  • deploying to different regions, including almost every US region and the Amsterdam region it gives me by default
  • deploying using a different dev machine

I’ve made sure Flyctl is updated to the latest version, which for me is 0.1.40.
Oddly enough the DB deployment always works, but the main project always fails with the same error message infiplaya1 has, with a different request id of course.

Is there anything we can do?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.