Error use of closed network connection

I changed my wifi network this morning, and after I am not able to deploy.

I get:

fly doctor
Testing authentication token… PASSED
Testing flyctl agent… PASSED
Testing local Docker instance… Nope
Pinging WireGuard gateway (give us a sec)… FAILED
(Error: ping gateway: no response from gateway received)
We can’t establish connectivity with WireGuard for your personal organization.
WireGuard runs on 51820/udp, which your local network may block.
If this is the first time you’ve ever used ‘flyctl’ on this machine, you
can try running ‘flyctl doctor’ again.
If this was working before, you can ask ‘flyctl’ to create a new peer for
you by running ‘flyctl wireguard reset’.
If your network might be blocking UDP, you can run ‘flyctl wireguard websockets enable’,
followed by ‘flyctl agent restart’, and we’ll run WireGuard over HTTPS.

What do I do here?

When I run wireguard reset or websockets enable, nothing seems to be happening for 10 minutes +

I’m having the same issues since this morning. After trying various options, I suddenly managed to ssh into machines. 1 hour later and the issue is back. I have now tried resetting Wireguard, restarting the agent (just hangs), killing the agent process, uninstalling flyctl etc. Nothing seems to work. Unable to deploy or ssh into a machine. Also tried switching to a different network, but the issue persists.

I can take a look. what gateway are you connecting to? (you can find the domain in .fly/config.yml)

Thank you for looking into this.

I am connecting to

Yes same here.

Edit: the wireguard reset that was running for 20+ mins finished, and it seems to work now

I restarted that gateway, should be working now?

1 Like

I works for me as well now. Thank you! :smiley: :clap: