Error tunnel unavailable: failed probing "personal": context deadline exceeded

trying to connect to my server to run a rake command and i’m getting this now.

i updated flyctl and re-authed. any other tips or things i should do?

side note: is there a way to kick off a long running rake task and close the terminal?

Getting this on deploying aswell, not sure what’s up

So this implies that your flyctl client is having trouble reaching your organization’s wireguard VPN. There are a few things you can to do check your local connection to your organization’s network:

  • fly doctor as a basic diagnostic: this will confirm that your agent/auth are working, and ping the wireguard gateway
  • bounce the connection: create a new wireguard peer, and remove the old one:
fly wg list # see which peer you're using
fly wg reset # generate a new one 
fly wg remove # remove the old one
  • other fly wireguard subcommands might come in handy, depending on what the underlying issue is
fly wg status
# view detailed statistics for a connection 
fly wg websockets enable
# tunnel wg traffic over websockets to sidestep LAN issues 

We’ll also be sure to look into this on our end to make sure everything looks OK on our end!


how many listings should there be under the list command? i reset and removed the others

when i run fly wg status i get:

Error upstream service is unavailable

So normally you’d see a list of the connections/peers that fly has made for you. We can definitely look into this for you. Is it just wg status? Are you able to see your connections via wg list?

i can see a list, yeah.

i have 2 items currently, unsure if i should share those

No, it’s okay-- I was just trying to quickly help rule out any issues with your local flyctl install. Have you tried enabling websockets (fly wireguard websockets enable) yet?

yeah, i think so

For me, this was due to low memory, scaling app will help

yeah, that seems to be a common response but i was already on the dedicated plan and accrued $~14 in the 4-5 days the app was running. not sure i need to spend more money just to connect to my instance.

i’ve since deleted the app though since there was no resolution

I don’t think it was RAM on yours, it was likely this: WireGuard Peers Got Faster Again, Again