Error: tunnel unavailable: failed probing "personal": context deadline exceeded

I’m trying to SSH into my app instance:

$ fly ssh console -C bash --app epic-stack-template
Connecting to tunnel 🌏Error: tunnel unavailable: failed probing "personal": context deadline exceeded

I tried following along with Error tunnel unavailable: failed probing "personal": context deadline exceeded. I listed all my wireguard peers (there were TONS), I removed them all (was that a bad idea?) and I reset to create a new one. Still no dice. I’m not sure what I’m doing wrong.

Any ideas?

Hey @kentcdodds - That error generally indicates an issue with your local wireguard agent. Can you try the following:

  • Reset your wireguard connection using fly wireguard reset
  • Restart the flyctl agent with fly agent restart (or fly agent stop and fly agent start)

If you’re still seeing issues after the above, setting the the wireguard connection to use websockets with fly wireguard websockets enable may also help.

Switching to websockets fixed it for me. Thanks!


We had a bug with v0.1.28 where any command that relied on user mode wg would fail when the wire_guard_websockets key was missing from ~/.fly/config.yml. We reverted the change that caused this and are releasing v0.1.29 shortly with the fix.

The issue can be mitigated with v0.1.28 by calling fly wg websocket disable or fly wg websocket enable—both will set the wire_guard_websockets key in ~/.fly/config.yml`.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.