Eror "Failed to start remote builder heartbeat: failed building options: failed probing "personal": context deadline exceeded"

when I deploy the application it’s always like that.
i use windows . This is my first time using
is there a way to solve it


It’s generally a networking issue somewhere along the line. So assuming you have no firewall blocking access at your end …

Try fly wireguard reset and then trying a deploy again.

If that does not fix it, try fly wireguard websockets enable and then trying a deploy again. That can help, using a websocket.

If that does not fix it, does fly doctor report any issues with your connection?


thanks you brother
i fix it withfly wireguard websockets enable


I fix it also with fly wireguard websockets enable

1 Like

I ran into the same problem. For me

fixed it. Maybe if these are obvious solutions to this error, flyctl should attempt or at least recommend them when this occurs.

1 Like

Unfortunately fly wireguard reset doesn’t work for me.

Yesterday the deployment worked but today it doesn’t.

Then I build using local docker instead.

I have the same issue, and fly wireguard reset or fly wireguard websockets enable are not working for me.

$ flyctl doctor
Testing authentication token... PASSED
Testing flyctl agent... PASSED
Testing local Docker instance... Nope
Pinging WireGuard gateway (give us a sec)... FAILED
(Error: ping gateway: no response from gateway received)

We can't establish connectivity with WireGuard for your personal organization.

WireGuard runs on 51820/udp, which your local network may block.

If this is the first time you've ever used 'flyctl' on this machine, you
can try running 'flyctl doctor' again.

If this was working before, you can ask 'flyctl' to create a new peer for
you by running 'flyctl wireguard reset'.

If your network might be blocking UDP, you can run 'flyctl wireguard websockets enable',
followed by 'flyctl agent restart', and we'll run WireGuard over HTTPS.
1 Like

$ flyctl wireguard
automatically selected personal organization: Jinkyou Son (Json)
| interactive-agent-<personal_info>-01HGQXDSRBGAQR91MTMP47S4Q6 | sin | |

Same issue here,
Samme errormessage as you got.

  • fly wg reset
  • fly wg websockets enable
  • fly agent restart
  • fly agent doctor

Nothing works anymore, worked fine a few days ago, and from my understanding, nothing has changed on my end.

1 Like

Same problem here. The interesting thing is that it just happens in specific organizations or apps.
Fly status also reports services as healthy:

1 Like

I have tried to create a new organization to check, but still won’t connect.
But i think sztupy is into something, i have an only IPv4 network as him. Maybe that’s why it won’t work?

That’s my idea, but it might be wrong. In any case as I mentioned in that thread I did start up a tiny linux instance on the web and from there the commands worked without a hitch, so that might be something you could try.

Managed to solve it on my end.

  • Created a new account
  • Logged out of the cli
  • Logged in on the cli with the new account
  • Ran “flyctl doctor” and it passed
  • Logged out of the cli
  • logged back in to the cli with the old account (the one i’m actually using and going to use)
  • ran “flyctl doctor” and it passed

Everything working again :slight_smile:

I fixed it.

  • destroy builder app fly apps destroy <builder_app>
  • try deploy (create new builder app)
  • reset wireguard fly wireguard reset
  • retry deploy (works)

I have tried this but doesn’t work still for me.

1 Like

Same here, nothing has changed on my end, still fails.

$ fly doctor
Testing authentication token… PASSED
Testing flyctl agent… PASSED
Testing local Docker instance… Nope
Pinging WireGuard gateway (give us a sec)… FAILED
(Error: ping gateway: no response from gateway received)

1 Like

Hi, I’m getting the same problem, tried all these solutions, nothing works.

I have a fresh app, I’ve also tried deploying in different regions (London, Paris, Amsterdam)

Some extra info:

  • For me my postgres db instance shows as “deployed” when I go through the website
  • But my main app shows as “pending”
  • Both of them get Error: ping gateway: no response from gateway received when I run fly doctor against them in the command prompt

Elevated deploy errors

  1. Investigating2023-12-06 00:28:28 UTCWe are currently investigating an issue with wireguard gateways which are preventing deploys.

when do you think this will be resolved?

We have an important demo tomorrow, and our deploy is borked :frowning:

Can someone please update on the expected timelines here? This is looking very bad for us