DNS resolution issues (resolves more IPs than actual app instances)


One of my apps recently started to reject random requests with timeouts. After some investigation I found out the following.

If I ssh into another app (gateway) in the same network and do dig AAAA [my-problematic-app].internal, I get 2 IPs in the answer section. Looks like one of these IPs is correct (at least I can see it in the start up logs of the problematic app), and the other one is not. I tried redeploying the app and also tried scaling the count up and down (even to 0), but the bad IP doesn’t go away.

What can I do in this situation?


Hey there,

That would’ve been a mistake from a little while ago. I cleaned it up for your app.

Only 1 record is returned now.

So the thing to do is definitely to bring it up with us!

Thanks! Seems to work perfect now.

By mistake you mean it was some problem with fly.io or did I do something wrong?

This was on us. A data migration gone wrong a little while ago.

1 Like

I wish I had an issue like this :smiley: My app doesn’t even get an IP resolved :eyes:

1 Like