DEFAULT Postgres Database creation is FAULTY

I’m not shure if this is a joke or something, but when I do

fly postgres create

to create a default database in Franfurt with free tier specs (first and default option) and just restart the app, it fails in health checks. I migrated a database a couple days ago from heroku and it has the same health check problems. But for some reason it is just not reachable anymore.

I’m not shure to use this service if the most basic stuff is broken…


Anyone from the DEVs here? I mean this bug just can’t be right…

Hi @josh-university, if you provide some details about what you tried and what output you saw, people will be more able to help. :smiley_cat:

You absolutely right. Here is the complete Rundown:

name@Names-MBP ~ % fly pg create       
? Choose an app name (leave blank to generate one): testsetup
automatically selected personal organization: Name Name
? Select region: Frankfurt, Germany (fra)
? Select configuration: Development - Single node, 1x shared CPU, 256MB RAM, 1GB disk
Creating postgres cluster in organization personal
Creating app...
Setting secrets on app testsetup...Provisioning 1 of 1 machines with image flyio/postgres:14.4
Waiting for machine to start...
Machine 3d8d3e4b95e389 is created
==> Monitoring health checks
  Waiting for 3d8d3e4b95e389 to become healthy (started, 3/3)

Postgres cluster testsetup created
  Username:    postgres
  Password:    PASSWORD
  Hostname:    testsetup.internal
  Proxy port:  5432
  Postgres port:  5433
  Connection string: postgres://postgres:PASSWORD@testsetup.internal:5432

Save your credentials in a secure place -- you won't be able to see them again!

Connect to postgres
Any app within the Name Name organization can connect to this Postgres using the following credentials:
For example: postgres://postgres:PASSWORD@testsetup.internal:5432

Now that you've set up postgres, here's what you need to understand:

Then I do:

name@Names-MBP ~ % fly apps restart testsetup
testsetup is being restarted

And return on the Dashboard is:

As I said, this is the most basic setting there is…
And somehow a deployed app has stopped working after a day and now i don’t know whats wrong…

Hey @josh-university ,

I’m sorry about that, it looks like we need to disable that command for apps running Machines. In your case, you should use: fly pg restart --app <app-name>.


without --app it actually restarted wrong. Thats also the reason, why my heroku migrated one didn’t work anymore. By the way i tried to recreate the heroku migration again and it didn’t work this time.

It always logged:

name@Names-MBP Database % fly pg connect -a app-database -d app
Oops, something went wrong! Could you try that again?

without --app it actually restarted wrong.

This doesn’t really make sense, but if you’re able to reproduce a difference please let us know!

fly pg connect -a app-database -d app
Oops, something went wrong! Could you try that again?

What’s the name of the postgres app you’re restoring into?

Hi shaun, i deleted all of the non working yesterday. i just did the tutorial step by step and it just didn’t work in the end. I don’t know.

My container that didn’t work when restarting without --app ist called ‘cell-map-analyser-db’.
It works now but i restarted it dozens of times without --app and it just wasn’t working but after a single time with the argument it worked.

You have to specify --app when you run commands unless you have pulled down your apps configuration file. If there’s no fly.toml file in your current path, you’ll have to specify --app.