connecting to observer on remote machine

Attempting to connect to quiet-cherry-7730@fdaa:0:3598:a7b:14bf:782c:be54:2
Erlang/OTP 24 [erts-12.2] [source] [64-bit] [smp:4:4] [ds:4:4:10] [async-threads:1] [jit]

Node Connected?: false
Connected Nodes: []

this is the output of bash ./observer when following this guide.

Why is Node Connected false?

I suspect because of that, I cannot see the remote node in my Observer.

Hello @abeeshake!

Is this still an issue for you?

If so, here’s some of the points to check:

  • Are you setting the OTP cookie explicitly?
  • Is the server instance able to cluster with other server instances? (does clustering work? Because the observer connection works through clustering)
  • Do you have an active wireguard connection open? If it’s not open, then it can’t reach the instances running on Fly.