Completely botched v2 migration

Using flyctl v0.1.101.

I ran flyctl migrate-to-v2, which didn’t complete successfully because of a failing health check. This app (pacman-ghost-gitea) is for Gitea, and the failing health check is for the SSH port. The main webapp was fine, though.

It asked if I wanted to troubleshoot the problem, I said “yes”, and it just dropped me back to the console.

I tried re-deploying, same problem.

I have another app running nginx that sits in front of my Gitea, which seems to have already been upgraded. I scaled it down to 0 and then 1, which worked fine. But SSH was still not working.

I then tried scaling the gitea app down to 0 and 1, but couldn’t scale back up:

App 'pacman-ghost-gitea' is going to be scaled according to this plan:
  +1 machines for group 'app' on region '' of size 'shared-cpu-1x'
  +1 volumes  for group 'app' in region ''

which fails:

Executing scale plan
  Creating volume pacman_ghost_gitea_data region: size:1GiB
Error: failed to create volume: no capacity available in 

Also can’t deploy:

Can't deploy
    No machines in group app, launching a new machine
    Error: error creating a new machine: failed to launch VM: Mounts source volume "vol_1g6734015onrydxw" is in the wrong region ("dfw" != "sin")

My volumes:

ID                      STATE   NAME                    SIZE    REGION  ZONE    ENCRYPTED       ATTACHED VM     CREATED AT     
vol_1g6734015onrydxw    created pacman_ghost_gitea_data 1GB     dfw     e163    true                            11 months ago 
vol_0o6d423oo38r87gy    created pacman_ghost_gitea_data 1GB     dfw     83f5    true                            1 month ago   
vol_od56vj51p2p4ny30    created pacman_ghost_gitea_data 1GB     dfw     ccb3    true                            1 month ago   
vol_9vlz678d1q1qlmgr    created pacman_ghost_gitea_data 1GB     dfw     e163    true                            52 minutes ago

I note that the volume flyctl is trying to mount (vol_1g6734015onrydxw) is an old one, and not the the one created by the migration tool (although isn’t it supposed to have a -machines suffix?).

In fly.toml:

      PRIMARY_REGION = "dfw"

So, something seems to be screwed up wrt which volume to use, and which region it’s in.

Hi, just wanted to let you know that we see this and are looking into it. There are multiple things wrong here - sorry your migration ended in a lousy experience.

Can’t even re-create this app from scratch because of volume problems :-/

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.