CNAME mismatch when using fly's custom domains + How to do apex domains w/o IPV4?

In the fly console, I have the error:

 The CNAME record for doesn't seem to match.

I tried removing the dot at the end of the CNAME record on namecheap, but namecheap seems to require it. What should I do?

As seen here, seems to think both domains are verified:

Yet, the domains look down to me.

Hey @vedantroy, since all fully qualified domain names technically end with a ., what you’ve entered into Namecheap should be correct. (I think the UI is including the final . in the first line but not in the second, which is confusing and should probably be fixed.) I also tried resolving the CNAME myself (with the dig command), and again it looked fine to me. The warning you found in the UI is a recent addition, and I’m wondering if there’s a bug causing a false positive.

Could you elaborate on what you’re observing that makes you say this? It might help us narrow down what’s going on.

Hmm, the domains were not working for a while, but now the domain is working.

However, the domain (without www) is not working. I notice that I’m only getting the CNAME warning (for domain ownership verification) for the domain, and not the domain.

This error doesn’t make sense. Your DNS is misconfigured because you are missing an A (IPv4) record on your apex domain

lillian ~ % dig a              

; <<>> DiG 9.10.6 <<>> a
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 3656
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1232
;			IN	A

;; AUTHORITY SECTION:		3247	IN	SOA 1683586374 43200 3600 604800 3601

;; Query time: 59 msec
;; WHEN: Mon May 08 22:00:44 EDT 2023
;; MSG SIZE  rcvd: 113

while it does have an AAAA record:

lillian ~ % dig +short aaaa

You have a CNAME record on that points to your app’s domain, but CNAME records are not supported on the apex, so you’ll have to add an A record for it.

I see, will fix. Maybe the UI should be updated to reflect this? Specifically, looking at the UI–I’m not sure what I’m supposed to do here.

I don’t see any mention of an A record. I used to use the terminal to setup domains, so I’ll take a look and see if the CLI gives better instructions.

Edit: I can’t create an ipv4 address, because my ipv4 IP is a shared IP. What should I be doing to resolve this?

Actually nothing is misconfigured–guess this time around namecheap + fly just took longer for the domain to get working?

The apex domain is misconfigured.

Looks like has fixed the UI. Closing.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.