Can't set --max-per-region value

We have an app in 3 regions.

I noticed that our app restarted for no reason and ran 2 apps in one region. We lost an instance in lhr region.

I tried setting the --max-per-region valye manually but got failure:
I see Max Per Region: Not set

and tried to redeploy the app.

Why did it happen? How can we fix this behaviour?

1 Like

This is causing an issue where sometimes we are missing a redis instance in a region.

Try setting flyctl scale count 3 --max-per-region=1 --process=app.

Do you have [processes] defined in your fly.toml?

when I run the command I see

Error unknown flag: --process

any idea?

I just ran into the same issue:

❯ fly scale count 1 --app snap-db-staging --max-per-region=4
Update available 0.0.256 -> v0.0.270.
Run "flyctl version update" to upgrade.
Count changed to 1

snap on  staging [$!] via  v16.13.1
❯ fly scale show --app snap-db-staging
Update available 0.0.256 -> v0.0.270.
Run "flyctl version update" to upgrade.
VM Resources for snap-db-staging
        VM Size: dedicated-cpu-4x
      VM Memory: 8 GB
          Count: 1
 Max Per Region: Not set

@kurt Happy Holidays! Any clue why we can’t set --max-per-region ? Currently it means our apps don’t rolling restart and go down every time we deploy.

There’s a bug causing The max-per-region value not to show up for the default app process. The command should have worked, but you can only verify it by scaling up to a larger count.