App is stuck in pending in `sin` region

Hi,

One of my engineers just pushed an update to deploy, and after seeing the deployment stuck in pending, he tried pushing twice more, and both ended up in pending.

I’ve tried suspending, scaling to 0 and then back up, and setting the region list to try moving the app to a different region, and all don’t seem to have helped clear the pending list.

Here’s the output from flyctl status --all
image

I’m not sure what else to do to try and debug this.

I don’t believe it’s the same issue as App stuck in Pending mode, no logs, - #17 by kurt because we have app timeouts set in our fly.toml, see below:

app = ""

kill_signal = "SIGINT"
kill_timeout = 5

[[services]]
  internal_port = 8000
  protocol = "tcp"

  [services.concurrency]
    hard_limit = 100
    soft_limit = 100

  [[services.ports]]
    handlers = ["http"]
    port = "80"

  [[services.ports]]
    handlers = ["tls", "http"]
    port = "443"

  [[services.tcp_checks]]
    interval = 10000
    timeout = 2000

Further update to this. After fully deleting the app, then trying to redeploy in sin, it got stuck in pending again. However, after fully deleting the app again, then setting region to nrt before first deploy, it no longer gets stuck in pending.

Sorry about that. Looks like one of our servers in Singapore was in a bad state and your app was being scheduled there.

Just fixed it. Should be good to set the region to sin again.

1 Like