One of my apps stuck in pending

Hi, I hope that this is the right place to ask.

I am having trouble deploying my 4th app (I’m on the hobby plan, but paying. I added pre-paid credit just to ensure it isn’t due to lack of funds on the account).

My other apps are fine but nr4 stopped deploying after a while and I cannot figure out why. It’s a simple go web backend service. All commands like fly status just hang forever, and when I look in the dashboard, it just says pending, without any logs.

There are no build errors or so, every deploy just ends with the cli tool giving me a link to the monitoring page, and then hanging there indefinitely.

Region is “arn”. Like I mentioned it worked 30 minutes ago, so idk what is going on now :smiley:

Could the region run out of cpu? (my apps are currently on the smallest instance level, I dont need anything else right now. 1shared cpu with 256 MB ram)

I can also mention that I destroyed the app and created it again, without any success (same result). fly deploy just hangs at Watch your app at

Having the exact same issue here (ord region).

Same issue, region WAW

Possible workaround:

Yep, this was a breaking change introduced in v0.1.47. Please upgrade to v0.1.48, since it should revert that change.

Unfortunately even at v0.1.52 it still happens about 25-50% of the time.

This is sort of possible to work around when doing manual testing (where you can just delete the app and launch it again from scratch), but for any kind of automation (like github actions) or my own “flycd” Project (a wannabe argocd imitation for it kind of kills the functionality unfortunately.

Well, at least now it’s consistently failing 100% of the time again :S, and now flyctl is logging a http 504 (gw timeout) response.

fly status returns the expected values.

fly logs shows an infinite number of “Pulling container image…” messages, even after destroying the app and trying again :D. I think must be down in general or something

1 Like

I observe the same behaviour - fly deploy for my application did nothing, it had stuck updating (app had worked as before but with regular “Pulling container image…” logs appearing). I’ve tried to destroy and re-launch the application and now it’s simply not starting

launching ended with the following statement:

Error: timeout reached waiting for machine to started failed to wait for VM 1781036c516689 in started state: Get “<…>”: net/http: request canceled
note: you can change this timeout with the --wait-timeout flag

UPD: one more fly deploy made the trick, app is running finally

Looks like v0.1.53 is released now, and behaving better when it comes to flyctl deploy.

However - I think I still have issues where images seem to be deleted from the fly image registry when a container ends up in a startup crash loop, but that is a separate issue I suppose… For example:

  1. create and deploy an app, the image is built…
  2. instantiates a container and executes it… the pull works
  3. the container reaches max number of startup crashes/retries, and shuts down/auto-suspends
  4. deletes the image …
  5. I fix the outside condition that caused the app to crash
  6. I restart the app… now it cant pull the image :smiley:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.