App instance stuck

My deploy failed and now it’s stuck and cleaning up

[info] thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: Error { tag: Tag::Default, profile: Some(Profile(Uncased { string: "default" })), metadata: None, path: [], kind: MissingField("versioning"), prev: None }', src/

2022-09-05T17:47:37.708 app[e3ffadfb] fra [info] note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace

2022-09-05T17:47:38.672 app[e3ffadfb] fra [info] Starting clean up.

Deploying v19

Deployment is running.

1 desired, 1 placed, 0 healthy, 0 unhealthy

i tried fly restart, didn’t help

fly vm stop, changed desired status to “Stop” but still stuck

Tried spamming deploys until one got through, everything works fine now

NOT solved 425026ea on v18 is still running with desired status “stop”

Same issue here — status is stuck on “stop” for us as well. I ended up ssh’ing into the container and killing the process to prevent the stopping instance from serving any traffic, but fly status --all still lists the instance (it’s been in “stopping” state for >1h; the culprit is the last row, ID b1f23696):

c8bed9ba	app    	46 ⇡   	fra   	run    	running 	1 total, 1 passing 	0       	35m58s ago          	
a460c025	app    	44     	fra   	stop   	complete	1 total, 1 passing 	0       	1h44m ago           	
702fe83e	app    	44     	fra   	stop   	pending 	                   	0       	2h0m ago            	
618bc21c	app    	42     	fra   	stop   	complete	1 total, 1 passing 	0       	2h8m ago            	
b1f23696	app    	41     	fra   	stop   	running 	1 total, 1 critical	0       	2022-08-29T00:45:01Z

It solved itself buf other people still seem to have the same issue? I saw at least two posts + this one ^.
I guess it just timed out?