"An unknown error occured" when running flyctl deploy

When I run the flyctl deploy command to try and deploy my app this evening, I receive the message Error An unknown error occured. immediately following ==> Creating release.

My Dockerfile appears to be building and pushing to Fly correctly, is this an issue on my end or on Fly’s?

This is on our end, will you give it another try in about two minutes?

It’s working now - thank you for the quick fix! :slight_smile:

@kurt Could you help us as well on a similar instance of this error? In our case, every step in the deployment builds up correctly (it’s a rails 6 app), and ends when “Creating release” with a similar “an unknown error occurred”.

happy to give you guys more details.

Looks like an error in our api. We’ll get it sorted out shortly.

Lovely, thank you for the swift response!

A fix was just deployed, can you try again?

Perfect, that was nice and easy! Just to make sure, removed the former app which was left on an error state. Recreated it and redeployed and it went all the way through!

1 Like

Glad it worked!