When I run fly launch to my project I get the following error: Error name argument or flag must be specified when not running interactively

Help me how to fix it. This is my first time running fly launch.

1 Like

I’m getting the same error. If it’s our first time launching, how are we supposed to know what are the correct variables/ parameters needed?

1 Like

That almost sounds like a bug but there’s a few things to check!

Usually this means you need to pass the command a flag (-a) with an application name.

The “launch” command shouldn’t need this.

The launch command should generate a fly.toml file, which has the app name in it (it has a prompt to ask you to supply an app name or it will auto generate one for you).

If you’re running a command (other than launch) without a fly.toml file in the current directory , you usually need to supply a -a flag and provide the app name.

  1. what OS are you running on?
  2. are you automating this somewhere that’s not allowing an interactive prompt? (e.g. in a CI pipeline)?

Hi! Thanks for the quick response.
I’m using Windows. I tried running this command in Powershell as well as CMD, but get the same error both times. No- not automating this from a pipeline.

Note that I’m trying this in a Python back-end app that I’ve already been able to deploy elsewhere…?

1 Like

Here is a screenshot of the error:

1 Like

I have the exact same error, on Windows 10, using cmd, cmder and powershell. Can be reproduced using fly launch even on an empty folder, started happening to me after updating from 0.0.396 to 0.0.435. Rolling back (renaming the .old files) solves it for now.

1 Like

Tried this with a new Remix app today and ran into the same error using PowerShell:

flyctl launch
Creating app in …
Scanning source code
Detected a Remix app
Error name argument or flag must be specified when not running interactively

I realize it doesn’t help, but here is what I am seeing:

PS C:\Users\rubys\tmp\y> flyctl version
flyctl.exe v0.0.435 windows/amd64 Commit: c5149629 BuildDate: 2022-11-22T16:41:44Z
PS C:\Users\rubys\tmp\y> flyctl launch
Creating app in C:\Users\rubys\tmp\y
Scanning source code
Detected a Remix app
? Choose an app name (leave blank to generate one):
1 Like

I was able to get it working by using the terminal in VS Code! Maybe the PowerShell in VS Code is more interactive? :sweat_smile:

I have the same flyctl version as rubys