flyctl on Windows when creating a new app: console UI does not work anymore

The app creation command produces strange results on Windows when running from the interactive command prompt:

> flyctl apps create
Error name argument or flag must be specified when not running interactively
> flyctl version
flyctl.exe v0.0.378 windows/amd64 Commit: e72b62b6 BuildDate: 2022-08-21T09:58:58Z

The last time I tried, it had a fancy console UI that guided through the app creation process. This time, it just stops claiming that I’m not in an interactive console session even though the session is clearly interactive.

> systeminfo | findstr /B /C:"OS Name" /C:"OS Version" /C:"System Type"
OS Name:                   Microsoft Windows 11 Pro
OS Version:                10.0.22000 N/A Build 22000
System Type:               x64-based PC
1 Like

Hi @Hypermind, did you ever find a solution to this? I’ve even gone so far as to wipe and reinstall it.

Just installed fly today and I am getting this error while creating a pg instance.

flyctl.exe v0.0.387 windows/amd64 Commit: d46c14f3 BuildDate: 2022-09-01T21:55:51Z

Appreciate the help. @Hypermind any luck?

I ended up specifying the command-line arguments for app creation manually. You can use the following command to get started:

flyctl apps create --help

Specifying app parameters manually is not super convenient but it works.

flyctl.exe v0.0.403 windows/amd64 Commit: 4386a944 BuildDate: 2022-10-02T15:52:19Z

I am also having this issue. Has persisted for about a month now.

One more workaround for that omission is to use the launch command:

> flyctl launch

Most of the times this is exactly what you want anyway, and it will create an app for you with a console wizard UI.

Hello, can you please share what arguments you used to get “flyctl launch” to work? I get the error:
“Error name argument or flag must be specified when not running interactively” but I’m not sure how the name argument is specified? Using ‘flyctl launch -help’ doesn’t provide that information. Thanks!

this doesn’t work

ok, so i installed with admin powershell. this lead to a broken installation i assume. after reinstalling in non-admin powershell, it seems to work as described