V2 Migration failed to migrate a secret correctly.

Last night some of my services started migrating automatically.
One of those services is berry-hasura-storage-sandbox This morning I noticed some requests were failing. upon debuggin it seemed that it had to do with a secret.

The secret in question is HASURA_GRAPHQL_ADMIN_SECRET

I ran fly secrets list and saw that the secret was still there
HASURA_GRAPHQL_ADMIN_SECRET fcde42cbf18b52348c399ae4bc109939 2022-07-08T21:48:51Z

I ran fly config save and then fly secrets set HASURA_GRAPHQL_ADMIN_SECRET=... to set the secret again just to be thorough.

Then my service started working again.

My guess is with the V2 migration, it migrated the secrets, but that one migrated incorrectly.

Luckily this was only a sandbox service.

I have another service that uses the same image and the same types of secrets: berry-hasura-storage-production I hope that, that service doesn’t fail to migrate.


We have identified the bug and are working on fix. Thanks for the report.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.