Unable to specify deploy


I originally had an apps name is “nekomi”, last updated nine days ago

Today I use “flyctl deploy” to specify, not to update to app “Nekomi”, but to recreate a new app.

How can I update an existing project to the app “Nekomi”?


great question!
one way to do it is to pass the app name to the -a or -app option for the command you’re trying to run on the app
another way to do it is to navigate to the directory with the app’s fly.toml
some of this is covered in our docs/flyctl doc strings, and this page might also be useful:


I already have a fly.toml, but it still doesn’t work

Where is the problem?



Just found out that it does work, although it generates a new app “fly-builder-crimson-river-448”

But the original app “Nejomi” does update and the app “fly-builder-crimson-river-448” status is always “pending”

Problem solved, thank you very much for your reply.

oh good, glad to hear it! fly-builder-crimson-river is the remote machine that fly deploy builds on. fly deploy will use those machines to build your app’s image in the case that it doesn’t detect local build tools for your app.

after a successful deploy, the app should reflect the changes made to its codebase. a re-deploy with the --remote-only option might do the trick?

the following posts might also come in handy if you need to run further deploy troubleshooting steps:

1 Like