Unable to execute Ecto-related commands via fly ssh

Hey there! :wave: My first post here, but did not feel the need to so far - all has been going well and any problems were easy to fix most of the time!
But today I got stuck. We have a company internal app, so it doesn’t receive much traffic. It mostly connects one of our systems with Slack to send messages, add people to channels etc. Normally I could do fly ssh console -C "app/bin/onboardme remote" and do tons of stuff in iex, but when I tried it today all I got was:

** (RuntimeError) could not lookup Ecto repo Onboardme.Infrastructure.Repository because it was not started or it does not exist
    lib/ecto/repo/registry.ex:22: Ecto.Repo.Registry.lookup/1
    lib/ecto/repo/supervisor.ex:160: Ecto.Repo.Supervisor.tuplet/2

What is more puzzling to me is that the dashboard for this app results in 500.

I tried restarting, but to no avail. The app has not been deployed in more than a month, totally unsure on what to do… Any ideas?

Thanks in advance!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.