unable to deploy via github actions or cli

We’re unable to deploy right now via either github action or cli. Ultimately, both fail with this error:

--> You can detach the terminal anytime without stopping the deployment
==> Monitoring deployment
Logs: https://fly.io/apps/kino-server-dev/monitoring
Error 1 error occurred:
	* No deployment available to monitor

Clicking through the link doesn’t provide any help – the logs look as if the deploy attempt never occurred at all.

I have the latest version of fly and have tried fly agent restart as well. Any guidance would be most appreciated!

I am having this same exact issue. I have also tried the same thing you did by restarting the agent. Googling has revealed that in the past this may have been due to an outage but I have no idea. Unless some one replies with a solution I am probably just going to wait a while and try again later.

1 Like

We’re currently having an incident that impacts Apps v1 deployments: Fly.io Status - Nomad deployments failing


Gotcha, thank you for the fast response!

Is there a rough ETA for this? Thinking of spinning up a digital ocean cluster temporarily as we want to get a bug fix out ASAP.

I can’t give you an ETA on Apps v1 deployments being back, but Apps v2 deployments (based on Machines rather than Nomad) aren’t impacted by this. Most of our issues these days are because of Nomad; anything running on the Machines platform should be a lot more stable.

Ah okay, thanks for the update! Is there a quick way we can move our app onto the machines v2 platform?

We’re working on a migrator tool, but it’s not quite ready yet. For now you can create a new app with fly launch --force-machines or fly apps create --machines and deploy as you would your v1 app.

What should we do for a V2 app that have the same problem?

I’m hitting this too. Dunno if I’m on v1 or v2 - I set this up a month ago following the tutorial. Same logs repeated forever in the builder:

2023-03-31T09:00:27.464 app[e286552dc43286] syd [info] time="2023-03-31T09:00:27.464445063Z" level=debug msg="checking docker activity"

2023-03-31T09:00:27.465 app[e286552dc43286] syd [info] time="2023-03-31T09:00:27.464886013Z" level=debug msg="Calling GET /v1.41/containers/json?filters=%7B%22status%22%3A%7B%22running%22%3Atrue%7D%7D&limit=0"

Please let us know your app name. The deployment processes of Apps v1 and Apps v2 are different and it is less likely to have the exact same errors.

Can you try fly apps list? What we call App v2 is listed as “Platform: machines”.

I’m back now (It was related to the outage that happened at that time). I was indeed on nomad. I need to look ino how to upgrade :slight_smile: