Unable to connect to my postgres instance


I´m no longer able to connect to my postgres instance for no aparent reason, somehow, the api deployed in fly.io is able to connect because I’m able to do requests against it.

But the issue is that I can’t connect to the postgres instance from my local computer anymore, I used to use DBeaver to connect. I tried exportin

Any ideas about how to troubleshoot it?

We are seeing the same atm. with our redis instance. Networking issue. We can’t even ping it from an app within the same organization via the .internal dns. Every now and then a few pings come through with ~15s lag. Not great. Similiar issues have happened about a dozen times throughout the past weeks. What’s going on?

I have the same issue. Wanted to dump database to migrate from fly to some other place, but even though proxy in theory connects to postgres server, I can’t connect to it

There’s definitely something going on right now. I have an instance in LHR that has gone through internal Fly network issue and now could not find an instance to route to with app status of pending for a little while now. Tried a restart and it sits at 1 desired.

Two restarts and 20 minutes later, my instance is back up and running. It took a couple of attempts for the deployer to get things working though, it appears.

I´m having a lot of issues with flyctl command, practically anything that I try to do hangs

Restarting machines is the correct way to fix this if your cluster is unhealthy.

Using fly machine commands, you can get a list of machines and then restart them. if you’re on the older platform doing fly restart <your-db-app> should do the trick.

Unfortunately postgres “high availability” has not been highly available, at least not as much as we’d like. It should be able to survive single node failures, but it doesn’t always. That’s why we’ve been working on a new postgres solution.

1 Like